Créer/Ouvrir les fichiers HFSQL Classic avec mot de passe

//Procédure pour générer/ouvrir fichier hfsql local par mot de passe

sMotDePasse est une chaîne = "BDIPrincipal"

 

//On parcours la liste des fichiers FIC

POUR TOUT CHAÎNE sFichierFIC DE HListeFichier(hLstNormal) SEPAREE PAR RC

 

     //Vérifie si le fichier existe

     SI PAS HFichierExiste(sFichierFIC) ALORS

 

     //Sinon on crée le fichier FIC avec le mot de passe défini

     HCréation(sFichierFIC,sMotDePasse)

 

FIN

 

//On ouvre le fichier fic avec le motdepasse défini

HOuvre(sFichierFIC,sMotDePasse)

 

FIN