Bloquer l'ouverture d'un menu-contextuelle depuis un événement

//On appel l"évenement qui va scruter l"ouverture d"un menu contextuelle sur l"écran en cours

//WM_CONTEXTMENU = 123 (correspond à l"ouverture d"un menu contextuelle)

Evénement(BloqueMenuContextuelle, MaFenêtre..Nom+".*", WM_CONTEXTMENU)

 

 

//Dans la fonction BloqueMenuContextuelle

//On gère l"exception, au cas où

QUAND EXCEPTION DANS

 

     //On récupère le champ en cours

     cChampsEnCours est une Champ <- ChampEnCours()

 

 

     //Si menu contextuelle personnalisé existe, on bloque l"affichge du menu

     //Certains menu on la valeur "+" a la fin du nom, on le remplace pour réaliser une comparaison valide

     SI Remplace(cChampsEnCours..MenuContextuel,"+","")="MENU_PERSO" ALORS

 

          //Va annuler l"ouverture du menu contextuelle MENU_PERSO

          RENVOYER Faux

 

     FIN

 

FAIRE

 

     //void

 

FIN