Génération d'une chaine de caractère aléatoire

//Procédure pour générer une chaine de caractère aléatoire

PROCÉDURE G_sChaineAléatoire(nTaille est un entier=6) : chaîne

 

sRetour est une chaîne

 

POUR i=1 _À_ nTaille

     InitHasard()

     nChoix est un entier = Hasard(1,3)

     InitHasard()

 

    SELON nChoix

          CAS 1

               sRetour += NumériqueVersChaîne(Caract(Hasard(48,57)))

          CAS 2

               sRetour += NumériqueVersChaîne(Caract(Hasard(64,90)))

          AUTRE CAS

               sRetour += NumériqueVersChaîne(Caract(Hasard(97,122)))

     FIN

 

FIN

 

RENVOYER sRetour